Teachers unable to view class details under the "My Classes" dashboard

Incident Report for Education Perfect

Resolved

This incident has been resolved
Posted Jun 18, 2026 - 02:35 NZST

Update

We are continuing to monitor for any further issues.
Posted Jun 18, 2026 - 01:44 NZST

Monitoring

We received reports from Canadian users that the My Classes dashboard did not load a list of classes as expected.

We have enabled a fix for this error on our end and are monitoring the results.
Posted Jun 18, 2026 - 01:43 NZST
This incident affected: Teacher Zone.