Errors accessing Education Perfect
Incident Report for Education Perfect
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 10:53 NZDT
Monitoring
Issue has been identified and a fix has been applied.
Posted Apr 04, 2024 - 17:15 NZDT
Investigating
We've received reports from some users that parts of Education Perfect are unavailable. We're investigating the issue now and will post an update shortly.
Posted Apr 04, 2024 - 17:02 NZDT
This incident affected: Teacher Zone and Student Zone.