Issues with assigning EP Create Activities

Incident Report for Education Perfect

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 04:07 NZDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2026 - 03:51 NZDT

Investigating

We are currently investigating issues of EP Create Activities seeing a "failed to assign work" error message in the assign flow. Our team is looking into the error now and will post an update shortly.
Posted Apr 01, 2026 - 03:00 NZDT
This incident affected: Teacher Zone.