CANADA ONLY: EP Create stuck in "Extracting Concepts"

Incident Report for Education Perfect

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 12:19 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2026 - 10:22 NZST

Investigating

We are currently investigating the issue
Posted Jun 24, 2026 - 09:25 NZST
This incident affected: Teacher Zone.