Issues with Library and Classwork pages

Incident Report for Education Perfect

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 06:16 NZDT

Identified

The issue has been identified, and a fix is being implemented.
Posted Mar 10, 2026 - 05:02 NZDT

Investigating

We are currently investigating reports of the Library and Classwork (Task & Assessment) sections of the platform not loading correctly. We're looking into the issue now and will post an update shortly.
Posted Mar 10, 2026 - 02:10 NZDT
This incident affected: Teacher Zone.