Issues loading Education Perfect website
Incident Report for Education Perfect
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 13:25 NZDT
Monitoring
We believe that this issue is now resolved but will continue to monitor the situation for any additional errors. If you continue to experience problems accessing Education Perfect, please reach out to our Support Team (support@educationperfect.com).
Posted Nov 30, 2022 - 11:29 NZDT
Update
We are continuing to investigate this issue.
Posted Nov 30, 2022 - 11:08 NZDT
Investigating
We are aware of an issue which is impacting users from accessing and signing into the Education Perfect platform. We are currently investigating this and hope to resolve this as soon as possible.
Posted Nov 30, 2022 - 11:07 NZDT
This incident affected: Teacher Zone and Student Zone.