Scoreboard Updates Delayed
Incident Report for Education Perfect
Resolved
This incident has been resolved.
Posted May 08, 2019 - 17:11 NZST
Monitoring
Scores are now updating normally, but we are continuing to monitor the situation.
Posted May 08, 2019 - 16:26 NZST
Identified
Due to high levels of usage, updates to scores in Education Perfect are currently not being processed immediately. Although this looks like your score is going backwards, don't worry; your results are queued and will be processed over the next few hours.

We'll update this post once the queued results have been successfully processed. In the meantime, you can keep on competing and your points will show up soon.
Posted May 08, 2019 - 13:07 NZST
This incident affected: Student Progress being stored and Competition Scoreboards up to date.