Upcoming Maintenance Notice - 2026-04-12

Scheduled for Apr 2, 09:00 NZDT  -  Apr 12, 08:00 NZST

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 01, 2026 - 13:11 NZDT

Scheduled

The Education Perfect website and app, or certain features of them, may be unavailable while we conduct maintenance. This will be between 4:00am and 8:00am AET / 6:00am and 10:00am NZT / 2:00am and 6:00am EDT on the 12th April 2026
Posted Mar 31, 2026 - 18:42 NZDT
This scheduled maintenance affects: Teacher Zone and Student Zone.