Delays in processing class and user additions and updates

Incident Report for Education Perfect

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 18:01 NZDT

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 06, 2025 - 17:30 NZDT

Investigating

We are currently investigating delays in processing class and user additions and updates.
Posted Feb 06, 2025 - 17:22 NZDT
This incident affected: Teacher Zone.