Slow scoreboard and progress updates
Incident Report for Education Perfect
Resolved
This incident has been resolved.
Posted Jul 01, 2019 - 11:35 NZST
Investigating
Updates to scores in Education Perfect are currently not being processed immediately. Although this looks like your score is going backwards, don't worry; your results are queued and will be processed over the next few hours.

We'll close this once your score updates are being processed normally.
Posted Jul 01, 2019 - 10:48 NZST
This incident affected: Student Progress being stored.