Issues with platform loading

Incident Report for Education Perfect

Resolved

This incident has been resolved. We experienced an unexpected and excessive database load, which caused significant performance degradation.
Posted Feb 25, 2026 - 17:53 NZDT

Monitoring

A fix has been implemented and we are monitoring the results
Posted Feb 25, 2026 - 16:38 NZDT

Investigating

There are some issues with areas of the platform. We are investigating this now.
Posted Feb 25, 2026 - 15:00 NZDT
This incident affected: Teacher Zone.