Scoreboard Updates Delayed
Incident Report for Education Perfect
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 10, 2019 - 11:29 NZDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 8 months ago. Jan 10, 2019 - 11:01 NZDT
Identified
Updates to scores in Education Perfect are currently not being processed immediately. Although this looks like your score is going backwards, don't worry; your results are queued and will be processed over the next few hours.

We'll update this post once the queued results have been successfully processed. In the meantime, you can keep on competing and your points will show up soon.
Posted 8 months ago. Jan 10, 2019 - 08:31 NZDT
This incident affected: Student Progress being stored, Competition Scoreboards up to date and Student Zone (Vocabulary).