Monitor and Response tabs for assigned Tasks do not load

Incident Report for Education Perfect

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 07:08 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 06:53 NZST

Identified

Our team has identified a potential cause of the issue, and is working on a fix.
Posted Jul 23, 2026 - 05:42 NZST

Investigating

We are currently investigating reports of the Monitor and Response tabs for assigned Tasks being stuck in a loading loop. We will provide updates as our team works to resolve this.
Posted Jul 23, 2026 - 04:49 NZST
This incident affected: Teacher Zone.