Issues loading Education Perfect

Incident Report for Education Perfect

Resolved

The incident has been resolved.
Posted Jun 26, 2025 - 17:49 NZST

Update

We are continuing to monitor for any further issues.
Posted Jun 26, 2025 - 17:15 NZST

Monitoring

A fix has been implemented and we are monitoring.
Posted Jun 26, 2025 - 17:07 NZST
This incident affected: Teacher Zone and Student Zone.