Accessing EP via Microsoft Edge results in "This site has been reported as unsafe" message

Incident Report for Education Perfect

Resolved

Microsoft Edge resumes allowing Education Perfect users to access the platform without any incorrect blocking.
Posted May 16, 2026 - 00:05 NZST

Monitoring

We have verified that users now have the expected EP experience when using Microsoft Edge, and we will continue to monitor.
Posted May 15, 2026 - 22:07 NZST

Investigating

We are currently investigating this issue. Please click "Continue to the unsafe site" or use another browser to access EP.
Posted May 15, 2026 - 15:58 NZST
This incident affected: Teacher Zone and Student Zone.