Troubleshooting steps for login issues
Incident Report for Education Perfect
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 14:21 NZST
Monitoring
Due to a recent update to our login page, some users have reported issues with logging into the EP platform.
If you're running into similar problems, please ensure you clear out your browser cache if accessing on a computer or ensure the EP Student app is up to date if working on a tablet before attempting to sign in once more.

Please reach out to our Support Team (support@educationperfect.com) with a screenshot of the specific error if this does not help resolve the issue.

For users signing in via SSO, please ensure you're using your schools exact name. If your school uses EduPass, you will now need to search for "EduPass" instead of your school name.
Posted Sep 12, 2022 - 16:07 NZST
This incident affected: Teacher Zone and Student Zone.