Issue creating Tasks and Assessments between 3-4:15pm NZST
Incident Report for Education Perfect
Resolved
Some teachers reported an issue creating tasks and assessments. This was an error on our end and has now been resolved.
Posted over 1 year ago. May 08, 2018 - 16:39 NZST
This incident affected: Teacher Zone (Tasks and Homework).